Discussion:
M_PLAYER tutoriels
(trop ancien pour répondre)
Arachide
2020-05-18 17:34:08 UTC
Permalink
Coucou,

Je sors la version 3.35 de M_PLAYER et j'en ai profité pour réaliser une
série de vidéos montrant les principaux aspects du logiciel:

(vidéos en français avec sous-titres en anglais désactivables)

https://gtello.pagesperso-orange.fr/mpl_tuto.htm

Et toujours la page de M_PLAYER pour le nouveau manuel mis à jour et le
téléchargement du logiciel:

https://gtello.pagesperso-orange.fr/mplayerf.htm

Guillaume.
OL
2020-05-19 16:36:54 UTC
Permalink
J'ai testé sous Mint XaAES et MyAES sur la V4SA driver fVDI en 32 bits en
haut à gauche j'ai le petit cadre VDI sélectionné en noir et
l'affichage marche très bien, les 2 versions. (noté 2.34 dans le
ressource de fin avril mais pas 2.35 comme indiqué sur le site)
En 16 bits le petit cadre n'est plus sélectionné et pas moyen de le
sélectionner, l'affichage ne se fait pas si je ne met pas l'option
xbiosfix dans fvdi.sys, une fois mis c'est très fluide.

Il y a quelques soucis tout de même:
- une sans doute lié à la machine, la touche contrôle n'a aucun effet
version superviseur ou pas.
- Si le nom du fichier vidéo fait plus que 8+3 alors le nom ne s'affiche
pas en entier dans le titre de la fenêtre.

Olivier
Post by Arachide
Coucou,
Je sors la version 3.35 de M_PLAYER et j'en ai profité pour réaliser une
(vidéos en français avec sous-titres en anglais désactivables)
https://gtello.pagesperso-orange.fr/mpl_tuto.htm
Et toujours la page de M_PLAYER pour le nouveau manuel mis à jour et le
https://gtello.pagesperso-orange.fr/mplayerf.htm
Guillaume.
Francois LE COAT
2020-05-19 17:45:02 UTC
Permalink
Salut Olivier,

Je ne sais pas ce que tu utilises pour poster des messages, mais ça
n'est pas diffusé sur les serveurs NTTP. Tu postes dans le vide !

Le problème semble être lié à "Nemo".
Post by OL
J'ai testé sous Mint XaAES et MyAES sur la V4SA driver fVDI en 32 bits
en haut à gauche j'ai le petit cadre VDI sélectionné en noir et
l'affichage marche très bien, les 2 versions. (noté 2.34 dans le
ressource de fin avril mais pas 2.35 comme indiqué sur le site)
En 16 bits le petit cadre n'est plus sélectionné et pas moyen de le
sélectionner, l'affichage ne se fait pas si je ne met pas l'option
xbiosfix dans fvdi.sys, une fois mis c'est très fluide.
- une sans doute lié à la machine, la touche contrôle n'a aucun effet
version superviseur ou pas.
- Si le nom du fichier vidéo fait plus que 8+3 alors le nom ne s'affiche
pas en entier dans le titre de la fenêtre.
Olivier
Post by Arachide
Coucou,
Je sors la version 3.35 de M_PLAYER et j'en ai profité pour réaliser
(vidéos en français avec sous-titres en anglais désactivables)
https://gtello.pagesperso-orange.fr/mpl_tuto.htm
Et toujours la page de M_PLAYER pour le nouveau manuel mis à jour et
https://gtello.pagesperso-orange.fr/mplayerf.htm
Guillaume.
--
François LE COAT
Auteur de Eurêka 2.12 (Grapheur 2D, Modeleur 3D)
http://eureka.atari.org/
Arachide
2020-05-19 21:07:08 UTC
Permalink
Post by OL
J'ai testé sous Mint XaAES et MyAES sur la V4SA driver fVDI en 32 bits
en haut à gauche j'ai le petit cadre VDI sélectionné en noir et
l'affichage marche très bien, les 2 versions. (noté 2.34 dans le
ressource de fin avril mais pas 2.35 comme indiqué sur le site)
En 16 bits le petit cadre n'est plus sélectionné et pas moyen de le
sélectionner, l'affichage ne se fait pas si je ne met pas l'option
xbiosfix dans fvdi.sys, une fois mis c'est très fluide.
- une sans doute lié à la machine, la touche contrôle n'a aucun effet
version superviseur ou pas.
- Si le nom du fichier vidéo fait plus que 8+3 alors le nom ne
s'affiche pas en entier dans le titre de la fenêtre.
Coucou Olivier !

En 32 bits, le bouton VDI c'est bon !
En 16 bits, pas de bouton... ça veut dire qu'il considère la V4SA comme
un équivalent de TT/Falcon avec une carte dans laquelle il peut écrire
directement !
Si ça pose problème (comme sur Aranym), je pourrais considérer la V4SA
comme Aranym et basculer sur un affichage 16 bits VDI. Mais ça ralentit!
Alors que si le XBIOSFIX rend l'écriture directe possible, c'est encore
mieux.

Il y a un cookie spécifique V4SA?

Le fait que le bouton VDI ne réagisse pas, c'estnormal : il est "read
only", c'est une info et pas un réglage.

Le CONTROL ne marche pas...???? Et avec MyAES, tu as accès au KBShift?

Pour les noms longs, en effet, je n'ai jamais géré ça... Si déjà ça
affiche le début du nom sans planter, c'est une bonne chose. Ensuite, ça
serait plus propre avec le nom entier.

Suis très content que tu aies fait ce test! Si la V4SA fait tourner
M_PLAYER, c'est qu'elle se rapproche d'un Atari.

Par contre, pas de son j'imagine...

Guillaume.
OL
2020-05-19 21:44:47 UTC
Permalink
Salut Guillaume

Ok j'avais déduit cela, ce qu'il serait bien c'est que l'on puisse
actionner le bouton VDI si on veut

Le Xbiosfix pour le moment sur cette machine rend les choses instables
malheureusement, je ne peux pas la laisser, ce n'est pas clair pour moi.

Pas de cookie V4SA rien pour distinguer à ma connaissance mais c'est
faisable facilement je pense dans emutos.

J'ai bien la touche control qui marche via l'appel kbshift mais moi je
ne l'appelle pas souvent (d'ailleurs pas la peine de l'appeler souvent 1
fois par seconde cela suffit)

Il est possible que en 0x4F2 il n'y ai pas la bonne adresse de sysbase,
faut que je regarde, le soucis c'est que la ROM n'est pas à la place
habituelle, je ne sais pas si Emutos gère cela, c'est juste une
réflexion c'est sans doute faux mais je vais regarder.

Non pas de son pour le moment je vais m'y atteler, tu sais aux dernière
nouvelles ils ont jusqu'à 16 canaux en 8 ou 16 bits! A ce qui parait le
son est top.

Ils ont aussi un mode vidéo (nous on supporte pas!) de 4 plans de 8 bits
pour les créateurs de jeux cela semble bien leur plaire!

Olivier
Coucou Olivier ! En 32 bits, le bouton VDI c'est bon !En 16 bits, pas
de bouton... ça veut dire qu'il considère la V4SA comme un équivalent
de TT/Falcon avec une carte dans laquelle il peut écrire directement
Si ça pose problème (comme sur Aranym), je pourrais considérer la
V4SA > comme Aranym et basculer sur un affichage 16 bits VDI. Mais ça
ralentit! Alors que si le XBIOSFIX rend l'écriture directe possible,
c'est encore mieux. Il y a un cookie spécifique V4SA? Le fait que le
bouton VDI ne réagisse pas, c'estnormal : il est "read only", c'est
une info et pas un réglage. Le CONTROL ne marche pas...???? Et avec
MyAES, tu as accès au KBShift? Pour les noms longs, en effet, je n'ai
jamais géré ça... Si déjà ça affiche le début du nom sans planter,
c'est une bonne chose. Ensuite, ça serait plus propre avec le nom
entier. Suis très content que tu aies fait ce test! Si la V4SA fait
tourner M_PLAYER, c'est qu'elle se rapproche d'un Atari. Par contre,
pas de son j'imagine... Guillaume.
J'ai testé sous Mint XaAES et MyAES sur la V4SA driver fVDI en 32 bits
en haut à gauche j'ai le petit cadre VDI sélectionné en noir et
l'affichage marche très bien, les 2 versions. (noté 2.34 dans le
ressource de fin avril mais pas 2.35 comme indiqué sur le site)
En 16 bits le petit cadre n'est plus sélectionné et pas moyen de le
sélectionner, l'affichage ne se fait pas si je ne met pas l'option
xbiosfix dans fvdi.sys, une fois mis c'est très fluide.
- une sans doute lié à la machine, la touche contrôle n'a aucun effet
version superviseur ou pas.
- Si le nom du fichier vidéo fait plus que 8+3 alors le nom ne s'affiche
pas en entier dans le titre de la fenêtre.
Olivier
Post by Arachide
Coucou,
Je sors la version 3.35 de M_PLAYER et j'en ai profité pour réaliser
(vidéos en français avec sous-titres en anglais désactivables)
https://gtello.pagesperso-orange.fr/mpl_tuto.htm
Et toujours la page de M_PLAYER pour le nouveau manuel mis à jour et
https://gtello.pagesperso-orange.fr/mplayerf.htm
Guillaume.
Arachide
2020-05-19 22:04:04 UTC
Permalink
Post by OL
Salut Guillaume
Ok j'avais déduit cela, ce qu'il serait bien c'est que l'on puisse
actionner le bouton VDI si on veut
Oui...
Faut que je regarde... Sinon, peux tu me donner les valeurs des cookies:
_CPU
_MCH
_VDO sur la V4?

Comme ça il n'y aura plus besoin du Xbosfix. Si je peux discriminer la
V4, je te fais une version rapidement qui sera en VDI du 16 au 32 bits.
Post by OL
Il est possible que en 0x4F2 il n'y ai pas la bonne adresse de sysbase,
faut que je regarde, le soucis c'est que la ROM n'est pas à la place
habituelle, je ne sais pas si Emutos gère cela, c'est juste une
réflexion c'est sans doute faux mais je vais regarder.
Oui! Ca serait intéressant de vérifier les pointeurs.
Merci!
Post by OL
Non pas de son pour le moment je vais m'y atteler, tu sais aux dernière
nouvelles ils ont jusqu'à 16 canaux en 8 ou 16 bits! A ce qui parait le
son est top.
Hé ben ! De quoi faire du mix sans temps processeur.
Si on pouvait avoir les mêmes adresses que le DMA... quel pied!
Post by OL
Ils ont aussi un mode vidéo (nous on supporte pas!) de 4 plans de 8 bits
pour les créateurs de jeux cela semble bien leur plaire!
Si je comprends bien, c'est 4 fois du 256 couleurs superposé? Avec des
transparences?

Guillaume.
OL
2020-05-19 22:12:18 UTC
Permalink
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF

Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le driver
car c'est maison.

Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3 des 4
(ceux de dessus) une valeur correspond à transparent. En gros c'est
comme les décors au théatre!
Post by Arachide
Post by OL
Salut Guillaume
Ok j'avais déduit cela, ce qu'il serait bien c'est que l'on puisse
actionner le bouton VDI si on veut
Oui...
_CPU
_MCH
_VDO sur la V4?
Comme ça il n'y aura plus besoin du Xbosfix. Si je peux discriminer la
V4, je te fais une version rapidement qui sera en VDI du 16 au 32 bits.
Post by OL
Il est possible que en 0x4F2 il n'y ai pas la bonne adresse de
sysbase, faut que je regarde, le soucis c'est que la ROM n'est pas à
la place habituelle, je ne sais pas si Emutos gère cela, c'est juste
une réflexion c'est sans doute faux mais je vais regarder.
Oui! Ca serait intéressant de vérifier les pointeurs.
Merci!
Post by OL
Non pas de son pour le moment je vais m'y atteler, tu sais aux
dernière nouvelles ils ont jusqu'à 16 canaux en 8 ou 16 bits! A ce qui
parait le son est top.
Hé ben ! De quoi faire du mix sans temps processeur.
Si on pouvait avoir les mêmes adresses que le DMA... quel pied!
Post by OL
Ils ont aussi un mode vidéo (nous on supporte pas!) de 4 plans de 8
bits pour les créateurs de jeux cela semble bien leur plaire!
Si je comprends bien, c'est 4 fois du 256 couleurs superposé? Avec des
transparences?
Guillaume.
Arachide
2020-05-20 14:24:48 UTC
Permalink
Post by OL
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF
Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le driver
car c'est maison.
Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3 des 4
(ceux de dessus) une valeur correspond à transparent. En gros c'est
comme les décors au théatre!
Intéressant pour l'Ethernet!

Je t'ai envoyé par mail une version de test.

Merci pour ton aide...

Guillaume.
OL
2020-05-20 20:05:01 UTC
Permalink
Salut Guillaume

Je te confirme que cela marche comme cela.

Olivier
Post by Arachide
Post by OL
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF
Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le
driver car c'est maison.
Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3 des
4 (ceux de dessus) une valeur correspond à transparent. En gros c'est
comme les décors au théatre!
Intéressant pour l'Ethernet!
Je t'ai envoyé par mail une version de test.
Merci pour ton aide...
Guillaume.
Arachide
2020-05-20 20:46:24 UTC
Permalink
Post by OL
Salut Guillaume
Je te confirme que cela marche comme cela.
Yeah !
Voilà une bonne chose de faite.
Je pourrais sûrement affiner la détection de la V4, mais pour l'instant,
on va dire ça.

Vivement que le son arrive...

En tout cas, merci beaucoup pour ton travail et tes tests sur la Vampire.
Ca nous aura fait un gros bout du travail quand on y viendra à notre tour.

Guillaume.
Post by OL
Olivier
Post by Arachide
Post by OL
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF
Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le
driver car c'est maison.
Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3 des
4 (ceux de dessus) une valeur correspond à transparent. En gros c'est
comme les décors au théatre!
Intéressant pour l'Ethernet!
Je t'ai envoyé par mail une version de test.
Merci pour ton aide...
Guillaume.
OL
2020-05-20 21:20:05 UTC
Permalink
Vu que tu fais de l'assembleur à tour de bras, ce serait bien que tu
essayes d'utiliser vasm pour Atari pour voir déjà si tu arrives à
compiler avec, ensuite cela te mettra un pied sur ce nouveau produit car
il y a des instructions CPU ammx qui permettent selon les auteurs de
fortement augmenter la puissance calcul

http://www.apollo-core.com/AMMX.doc.txt

Olivier
Post by Arachide
Post by OL
Salut Guillaume
Je te confirme que cela marche comme cela.
Yeah !
Voilà une bonne chose de faite.
Je pourrais sûrement affiner la détection de la V4, mais pour l'instant,
on va dire ça.
Vivement que le son arrive...
En tout cas, merci beaucoup pour ton travail et tes tests sur la Vampire.
Ca nous aura fait un gros bout du travail quand on y viendra à notre tour.
Guillaume.
Post by OL
Olivier
Post by Arachide
Post by OL
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF
Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le
driver car c'est maison.
Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3
des 4 (ceux de dessus) une valeur correspond à transparent. En gros
c'est comme les décors au théatre!
Intéressant pour l'Ethernet!
Je t'ai envoyé par mail une version de test.
Merci pour ton aide...
Guillaume.
Arachide
2020-05-21 08:03:08 UTC
Permalink
Coucou Olivier,

Oui, les instructions Ammx semblent intéressantes. Déjà pour M_PLAYER
les outils de conversion de modes couleurs en une seule instruction.

Je vais regarder VASM...
Ce qui me fait peur ce sont les MACROS que j'utilise énormément dans mon
source. Si le format ou si les possibilités sont différentes, ça va être
bien dur d'adapter les 35000 lignes de code...

En plus, je fais des boucles d'assemblage. C'est à dire que ASSEMBLE
passe plusieurs fois sur les mêmes lignes de code avec des options qui
changent (par exemple pour décoder du CINEPAK en 16 bits, ou en 256 gris)

Faut voir les possibilités de VASM en la matière.

Autre idée serait d'utiliser des MACROS dans ASSEMBLE pour intégrer les
nouvelles instructions.

A suivre...

Guillaume.
Post by OL
Vu que tu fais de l'assembleur à tour de bras, ce serait bien que tu
essayes d'utiliser vasm pour Atari pour voir déjà si tu arrives à
compiler avec, ensuite cela te mettra un pied sur ce nouveau produit car
il y a des instructions CPU ammx qui permettent selon les auteurs de
fortement augmenter la puissance calcul
http://www.apollo-core.com/AMMX.doc.txt
Olivier
Post by Arachide
Post by OL
Salut Guillaume
Je te confirme que cela marche comme cela.
Yeah !
Voilà une bonne chose de faite.
Je pourrais sûrement affiner la détection de la V4, mais pour
l'instant, on va dire ça.
Vivement que le son arrive...
En tout cas, merci beaucoup pour ton travail et tes tests sur la Vampire.
Ca nous aura fait un gros bout du travail quand on y viendra à notre tour.
Guillaume.
Post by OL
Olivier
Post by Arachide
Post by OL
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF
Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le
driver car c'est maison.
Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3
des 4 (ceux de dessus) une valeur correspond à transparent. En gros
c'est comme les décors au théatre!
Intéressant pour l'Ethernet!
Je t'ai envoyé par mail une version de test.
Merci pour ton aide...
Guillaume.
OL
2020-05-21 21:07:54 UTC
Permalink
Au fait Guillaume, est ce que Mplayer est sensé fonctionner en 16
couleurs 800*600 ?

En fait je n'arrive pas à le lancer sous Emutos et la V4

Olivier
Post by OL
Salut Guillaume
Je te confirme que cela marche comme cela.
Olivier
Post by Arachide
Post by OL
_CPU : 0x28 (68040)
_FPU : 0x80000
_VDO : FFFFFFFF
_MCH : FFFFFFFF
Son : en DMA
Tiens la carte ethernet est en DMA aussi (encore faut il faire le
driver car c'est maison.
Oui ces 4 plans superposés en 256 couleurs et je pense que pour 3 des
4 (ceux de dessus) une valeur correspond à transparent. En gros c'est
comme les décors au théatre!
Intéressant pour l'Ethernet!
Je t'ai envoyé par mail une version de test.
Merci pour ton aide...
Guillaume.
Loading...